Android requires compiler compliance level Hatası

Android projenizi sanalda veya cihaz üzerinde derlediğinizde şöyle bi hata alabilirsiniz.

Android requires compiler compliance level 5.0 or 6.0. Found '1.7' instead.

Bu hata çoğunlukla internet üzerinden bizim yapmak istediğimiz bir konuyu daha önce tutorial şeklinde hazırlayıp kanak kodlarıyla paylaşan arkadaşların dosyalarını indirip çalıştıracakken başımıza gelen bir hatadır. Bu hatanın özü şudur: bilgisayarınızda bulunana JDK sürümüyle tutoriali yapan arkadaşın projeyi derlediği makinedenki JDK sürümleri uyumsuzdur. Büyük ihtimalle de siz bir kaç sürüm sonraki JDK yı kullanıyorsunuzdur. Bu durumda ne yapılmalı.

Bu hatanın iki türlü çözümü bulunuyor.

Birincisi : projenin üzerinde sağ click> android tools>Fix Project Properties seçmek.
İkincisi : eğer birinci yöntemle halen başarılı bir şekilde derleme yapamıyorsanız projenin üzerinde sağ click>properties>Java Compiler. gelen pencerede Enable project specific settings kutucuğunu işaretleyip Compiler compliance settings seçmelisinden 1.5, 1.6 (makinenizde uygun kurulu olan sürüm) seçmek.

Hope it works.